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Word processing software is required for the creation of documents that are text-based. 
It has tools that allow the user to edit, format and print document. 
 

The main screen of OpenOffice Writer consists of different components like Tabs, Ruler 
bar, Status bar, Scroll bar and Work Area. 

Tabs: (File, Edit, View, Insert, etc.) contain drop down menu which have commands 
provided by the tab.  

Ruler Bar: There are two rulers – Horizontal and Vertical. The Ruler Bar allows us to 
adjust the indentation and margins.  

Status Bar: It displays information about the current open document. It displays the 
current page number, total pages in the document, zoom slider etc.  

Scroll Bar: There are two scroll bars – horizontal and vertical. They help to scroll the 
content or the body of document.  

 Work area: It is the working area where the text of the document is typed.  
 

Insert Hyperlink: <Insert> <Hyperlink>: A dialog box opens. On the left side of 
the dialog box, select where you want to link – a webpage, document, mail or to a new 
document. Then fill the details path, Form (text, button), etc. The Text is the name that 
appears in your document as hyperlink.  

Insert Table of Content: <Insert> <Indexes & Tables> <Indexes & Tables>: A 
dialog box appears. In Type, select Table of Content. Click OK. A table of content will 
be inserted in your document.  
Insert Table: <Insert> <Table>: A dialog box appears. Enter the table name, 
number of rows and columns. Click OK. A table is inserted in the document. A table 
toolbar appears which allows you to format the table.  

Insert Formula: <Insert> <Object> <Formula>: A pop up menu of elements 
appears. Select the element and write the formula. Figure 1.12b shows an example.  
 

The Format tab consist of commands required for formatting the document. The 
commonly used commands allow the user to format a page, paragraph, insert bullets, 
styles, formatting, etc. in the current document. 
 
The Table tab consists of commands that operate on a table. The commonly used 
commands allow the user to insert a table, insert or delete rows, or columns in a table, 
etc. in the current document. 
 
Some operations performed using the commands of the Table tab are described as 
follows -  



Convert Table to Text or Text to Table: <Table> <Convert>: A pop up menu 
appears. If text is to be converted to table, the Text to Table option appears, Select it to 
convert text to table. If a table is already present, then Table to Text option appears.  
 
The Tools tab consists of commands that can be used on the document for better results. 
The commonly used commands allow the user to check spelling and grammar of the 
content in the document, and count the number  of words and characters in the 
document. 
 
Some operations performed using the commands of the Tools tab are described as 
follows -  
Check Spellings and Grammar: <Tools> <Spelling and Grammar>: The grammar 
and spelling of the document is checked. A window appears if there are no grammatical 
and spelling errors in the document. If errors are there, then the errors are displayed with 
suggestions of correcting it. The user can decide to accept the suggestion or ignore it.  

Find Number of Words: <Tools> <Word Count>: If the text is already selected, 
then word count displays the number of words and characters in the selected text. 
Otherwise the word count displays the number of words and character in the whole 
document  
 

Spreadsheet 
A spreadsheet stores data in the form of a table comprising of rows and columns. It is 
used to store, arrange, and sort data, and perform calculations on numeric data. 
 
Following are some of the popular uses of spreadsheets:  
1. Managing financial data such as bank account information, budgets, transactions, 
billing, and receipts.  
2. Handling inventory, reviews, employee information, surveys, etc., using data entry 
forms.  
3. Tracking student performance by calculating grades and other relevant information 
such as attendance, highest score, and lowest score.  
4. Creating lists of items which may not be numeric such as student list, grocery list.  
5. Managing company information such as profit and sales by creating graphs from the 
data. 
 
The various menus and toolbars available in the main window of Calc are: 

Title Bar: The title bar at the top displays the information about the spreadsheet such 
as name of the current spreadsheet (ExampleSheet), extension of the spreadsheet (.ods), 
and name of the software (OpenOffice Calc).  
 

Menu Bar: Just below the title bar is the menu bar. It contains various menu options.  




File: It contains commands to create a new file (New), open an existing file (Open), 
save a file (Save , Save As), print a file (Print), preview a page (Preview Page), close a 
file (Close), exit the software (Exit) etc.  
 
Edit: It contains commands to edit a file such as Cut, Copy, Paste, Paste Special, 
Select All, Find & Replace, Delete Contents, Delete Cells, Headers & Footers.  
 
View: It contains commands to modify the view of the Calc such as Toolbars, Full 
Screen, Zoom. A small in front of the Toolbars options means on selecting it, another 
submenu appears which shows the list of all the toolbars which can be selected or 
deselected based on the user’s choice of toolbars to be displayed on the Calc main 
window.  

Insert: It contains commands for inserting Cells, Rows, Columns, Sheet, Sheet 
From File, Function, Function List, Picture, Chart etc.  
 
Format: It contains commands to alter the layout of the spreadsheet such as 
formatting Cells, altering Rows, Columns, Sheet.  
 
Tools: It contains options to o spellcheck (Spelling), insert macros (Macros) etc.  
 
Data: It contains commands to manipulate data such as Sort, Filter, Validity.  
 
Window: It contains commands to modify the window such as New Window, 
Close Window.  
 

Help: It contains the options getting help related to OpenOffice Calc such as 
OpenOffice Help, What’s This?, Check for Updates etc.  
 

Standard Bar: It lies below the Menu bar. It contains icons which perform similar 
operations as contained in the Menu bar options such as New, Open, Save, Print, Page  
Preview, Cut, Copy, Paste, Sort, Chart, Find & Replace, Spelling.  

Formula Bar: On the left side of the Formula bar is the Name box which contains a 
letter and name combination such as C4, whenever you select a cell on the spreadsheet.  

Status Bar: Status bar at the bottom provides information about the spreadsheet and 
convenient ways to quickly change some of its features.  
 

Types of Operators:  

Arithmetic Operators : Addition, Subtraction, Multiplication, Division, Exponentiation. 
Comparison Operator: Equal to, Less than, Greater than, Less than equal to, Greater than equal 
to, Not equal to. 
 



Functions: 

Calc has a set of predefined formulas called functions. 
Apart from SUM () there are various commonly used mathematical functions in Calc 
which are discussed as follows:  
1. PRODUCT (n1; n2…) – To calculate the product of arguments n1, n2…  
2. SQRT (n) – To calculate the square root of a number n.  
3. POWER (n; p) – To calculate power p of a number n.  
4. LOG (n; b) – To calculate log a number n to base b.  
5. ROUND (n; d) – To round a number n to digits d. 
6. SIN (n), COS (n), TAN (n) – To calculate sine, cosine and tangent of n.  
7. RAND BETWEEN (f; l) – Returns a random number between f and l.  
8. QUOTIENT (a; b) – To calculate integer quotient of division a/b.  
9. ABS (n) – To calculate the absolute value of a number n.  
10. AVERAGE (n1; n2….) – To calculate average of arguments n1, n2…. 
 
Relative Addressing: All cell references are by default relative i.e., they adjust and 
change when copied or when using AutoFill. When you enter an address A in a cell B 
then Calc does not store the actual address of A but instead it stores the number of rows 
and columns relative to the cell containing the address B or in other words how to reach 
A from B. 
Absolute Addressing: In some cases, the requirement is to retain the cell address even 
if it is copied to some other cell or when using AutoFill. In such cases, absolute 
addressing is used. Dollar signs ($) are used to hold a column and/or row address 
constant. When you enter an address in a cell that is prefixed with a $ sign, then Calc 
stores the absolute address of the cell. 
Mixed Addressing : Sometimes a combination of absolute and relative addressing is 
used such as $A3, B$5, A5+$B4, $A1+B$1. In such cases, whichever part (row or 
column) is prefixed with $ remains unchanged and the ones not prefixed with $ are 
calculated in a relative manner. 
 
 

Sorting: Data can be easily sorted in Calc by using the sort command available on the 
Standard toolbar (Sort Ascending , Sort Descending ) 
 

Steps to sort data in ascending order using the Standard Toolbar:  
Step 1: Select the cells you want to sort.  
Step 2: Click on the Sort Ascending icon on the Standard Toolbar.  
Data will be sorted according to the first column of the selected cells.  

Steps to sort data in ascending order using the Sort command:  
Step 1: Select the cells you want to sort.  
Step 2: Click on the Sort option in the Data menu which opens a dialog box.  
Step 3: You can change the select the column based on which you want to sort  
the data. Also, you can select the Ascending or Descending option.  
Step 4: Click on OK. 



 

Sorting using Multiple Columns:  
You can also select multiple criteria (up to 3) to sort with each criterion applied one 
after the other. 
 
Filtering Data : Applying a filter means displaying data based on some conditions or 
filters. 
Three types of filters can be applied – AutoFilter, Standard Filter and Advance Filter. 
 

Creating Charts and Graphs: 

In Calc, you can create graphs and charts to represent the data graphically. Sometimes, it 
is very difficult to analyze spreadsheets containing huge amount of data. 
 
Various types of charts can be created in Calc. It offers a choice of 10 chart types such 
as Column chart, Bar chart, Pie chart, Area chart. Each of the chart types has several 
sub-types. 
 
Creating Charts : Following are the steps required to insert a chart:  
Step 1: Select the data which is to be included in the chart.  
Step 2: Go to the Insert menu and select the Chart option or another way is to click on 
the Chart icon in the Standard toolbar. 
 
Macros: 

A macro is a recording of each and every command and action you perform to complete 
a task. A macro records your mouse clicks and keystrokes while you work and play 
them back later. 
 

Impress: 
 
Presentation software is required for the creation of the presentations for a larger 
audience. The presentation software has tools that allow the user to create presentations 
with sound, text, movies, pictures, and tables. 
 
The main screen of OpenOffice Impress is shown in Figure 5.2. It consists of different 
components like Tabs, Ruler bar, Status bar, Scroll bar, and Slide Pane. 

Presentation software allows creation of presentations having text, audio, video and 
pictures.  

 OpenOffice Impress is an open source software for presentation.  

 Tabs, Ruler bar, Status bar, Scrollbar and Slide Pane are the different components of 
OpenOffice Impress.  

 OpenOffice Impress has eight tabs – File, Edit, View, Insert, Format, Tools, Slide 
Show, and Window.  



 The slides can be viewed in different views – Normal, Outline, Notes, Handout, and 
Slide Sorter.  

 Normal view is the main editing view for creating slides.  

 Notes allows the user to make notes for the selected slides.  

 Slide Sorter view presents slides in a miniature form.  

 Slide Master allows making changes in appearance of the slides, applying changes to 
all slides in the presentation.  

 File tab allows operations on a presentation, like, create, save, print, open and close.  

 Edit tab is required to perform editing on the presentation, like, cut, copy, paste, find  
   & replace, undo and redo changes.  

View tab consist of commands required for viewing the current presentation on the 
screen to view slides in different layouts, status bar, ruler and sidebar.  

 Insert tab is required for inserting slide, page number, date and time, pictures, sound 
and hyperlinks in a presentation.  

 Format tab allows formatting the slides - character, paragraph, slide design and slide 
layout.  

 Tools tab contains commands to check spelling of content in the presentation.  

 Slide Show tab consists of commands used on the presentation for better results.  

 Slide transition is the pattern that applies when a slide goes from one to next.  

 Slide animation is the pattern that applies to elements of a single slide.  

 Windows tab consists of commands that work on a window, like, open and close a 
window.  

 Help tab provides help to the user of OpenOffice Impress software.  
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
Note: ‘Content developed/prepared absolutely from home. 


